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Blacklisting durch Borderware MXtreme Mail-Firewall

Einer unserer eigenen Mailserver ist vor kurzem auf der BSN-Blacklist von Borderware gelandet. Bei der Ursachenforschung haben sich einige Details gezeigt, die sicher auch für andere Betroffene interessant sind. Wir haben die wichtigsten Punkte für Sie zusammengefasst.

Fall 1: Sie selbst setzen eine Borderware MXtreme Mail Firewall ein.

Problem:
Sie bekommen keine Mails über die für Ihre Domain eingetragenen Fallback-MX-Server (interner Link), z.B. mail.LF.net oder fb-mx.LF.net. Die Absender der E-Mails erhalten Meldungen, dass ihre an Sie adressierte E-Mails nicht zustellbar sind.
Ursache:
Vermutlich steht der Server, über den die Mail verschickt werden soll auf einer Blacklist von Borderware (http://bsn.borderware.com/ (externer Link)).
Schema Mailtransport
  1. Mailzustellung an den Fallback-MX-Server
  2. Versuch, die Mail auf den Final-MX (hier: MXtreme) zuzustellen
  3. MXtreme fragt Borderware, ob die IP-Adresse des Fallback-MX auf der Schwarzen Liste steht
  4. MXtreme lehnt die Mail ab
  5. Der Fallback-Server benachrichtigt den Absender, dass seine E-Mail abgelehnt wurde
Lösung:

Konfigurieren Sie Ihr Borderware-System so, dass es das Blacklisting der für Ihre Domain zuständigen Fallback-MX-Server ignoriert (unklar, ob das wirklich möglich ist, fragen Sie Borderware) oder setzen Sie ein System ein, das E-Mails nicht aufgrund eines einzelnen Blacklist-Eintrags abweist.

Alternativ können Sie im Zonenfile Ihrer Domain die MX-Einträge entfernen lassen, die auf Server zeigen, die in der Borderware-Blacklist stehen. Damit wird nicht mehr versucht, Ihnen über diese Server E-Mails zuzustellen.

Den Fallback-MX-Server aus der Blacklist zu entfernen ist keine nachhaltige Lösung, da er jederzeit wieder auf der Blacklist landen kann (siehe unten, Hintergrundinformationen).

Fall 2: Der gewünschte Empfänger setzt Borderware MXtreme ein

Problem:

Sie versenden Ihre Mail über einen LF.net Mailserver, die Mail kommt aber nicht beim Empfänger an sondern Sie erhalten eine E-Mail mit dem Betreff: "Mail delivery failed: returning message to sender" und einem Inhalt ähnlich dem folgenden:

-----Ursprüngliche Nachricht-----
Von: Mail Delivery System [mailto:Mailer-Daemon@mail.LF.net]
Gesendet: Dienstag, 25. Juli 2006 14:32
An: Absender der unzustellbaren Mail
Betreff: Mail delivery failed: returning message to sender


This message was created automatically by mail delivery software.

A message that you sent could not be delivered to one or more of its
recipients. This is a permanent error. The following address(es) failed:

  Empfänger@Domain
    SMTP error from remote mail server after RCPT
TO:<Empfänger@Domain>:
    host mailserver@Domain [192.0.34.166]:
    554 Blocked by Intercept: go to
http://intercept.borderware.com/lookup?ip=212.9.160.2

------ This is a copy of the message, including all the headers. ------
------ The body of the message is 668277 characters long; only the first
------ 106496 or so are included here.
Ursache:
Vermutlich steht der Server, über den die Mail verschickt werden soll, auf einer Blacklist von Borderware (http://bsn.borderware.com/ (externer Link)).
Lösung:

Bitten Sie den Empfänger, den Mailserver, über den Sie die Mails verschicken, in seine Whitelist aufzunehmen oder alternativ, E-Mails nicht nur auf Basis dieser einen Blacklist abzulehnen. Den Mailserver aus der Borderware-Blacklist zu nehmen ist leider nicht nachhaltig, Details siehe unten.

Sollte beides nicht möglich sein, fragen Sie uns bitte nach einem Workaround.

Hintergrundinformationen

Wir haben von Borderware erfahren, dass diese Blacklist automatisch von MXtreme Systemen erzeugt wird. Erkennt ein MXtreme System eine E-Mail als Spam, wird der einliefernde Server als Quelle von Spam bei Borderware gemeldet. Um zu verhindern, dass ein Fallback-MX-Server — dessen originäre Aufgabe es ja ist, E-Mails weiterzuleiten — auf diese Blacklist gerät, muss jeder MXtreme-Kunde eine Liste von „friendly hosts“ pflegen, in die er alle Server einträgt, die regulär E-Mail an ihn weiterleiten. Unterlässt er dies — ganz egal ob aus Unkenntnis, Nachlässigkeit oder in böser Absicht — geraten unsere Server automatisch auf die Blacklist von Borderware. Mit den Worten von Borderware: unsere Server verlieren ihre „Reputation“ — und zwar ohne, dass wir direkt Einfluss darauf nehmen können.

In Anbetracht dieser Tatsache, klingt folgende Aussage auf der Borderware BSN-Website dann doch sehr zynisch:
„Did you know your reputation can change in seconds? Having a bad reputation could mean your network is vulnerable. Contact BorderWare today to learn how we can help!“

Wir halten die Praxis, Fallback-MXe und andere Relay-Server per default in eine Schwarze Liste aufzunehmen für inakzeptabel. Umgekehrt sollte nie nur aufgrund eines einzelnen Blacklistings eine E-mail abgewiesen werden, insbesondere nicht auf Basis einer Liste, deren Inhalt auf fragwürdige Weise zustandekommt. Bessere Systeme verwenden immer Kombinationen mehrerer Filter, um E-Mails zu beurteilen.

„Reputation“

Hier können Sie die „Reputation“ unserer Server selbst testen.

Frank Heydlauf, LF.net Netzwerksysteme GmbH
$Id: borderware.inc,v 1.12 2009/05/07 12:50:23 fernst Exp $